Up for sale is my 2002 Triumph Speed Four, 600cc naked sport bike. The Speed Four was made from 2002 to 2006 as the naked, or non-faired brother of the TT600 sport bike. The engine is a 599 cc inline-four-cylinder engine, as used in the TT600. It is rated at 96hp. The bike has a top speed of 135 mph and has a tested 0 to 1⁄4 mile time at 11.65 seconds @ 114.9 mph and 0 to 60 miles per hour time at 3.71 seconds. From my research Triumph only produced about 6,000 of them in the four years of production and only about 1,100 where imported to North America. This makes it a very uncommon motorcycle. Its the only one I’ve ever seen in person. I’ll let you decide if “rare” means valuable.

Now as for this motorcycle, it is good-ok condition. It has 27,000 miles on it and a clean title that I have in hand. I do not know anything about the history of the bike before I bought it. I bought it 2 years ago and have ridden it regularly since. The color is Triumph Roulette Green with British Royal Air-force Roundels on the gas tank.

Cosmetically the bike is nice for its age and mileage. It has nicks and scratches from riding and handling. The worst seeming to be the scuff on the front air scoop and a paint chip on the gas tank. The chip on the tank is covered by the roundel. It does have aftermarket handle bars as the bike originally had clip ons. The Speed Four is lowered by a lowering link which was done before I bought it. Overall cosmetically it is in good shape. The bike has an aftermarket exhaust that sounds great and is loud. The right passenger peg is broken on the motorcycle. It still functions but no longer stays in the folded up position. I zip tied it up because I thought it looked better that way.

Mechanically the motorcycle is okay and completely rideable. It starts, stops and rides great. I rode it all this season and just stopped two weeks ago. However it does have some issues. First, it has a high idle issue. When the bike is cold, it will rev up to about 4-5,000 rpm until it reaches operating temperature. This usually takes about 1 minute. Once it is warm it idles, runs and starts like normal. It may be a vacuum leak, unfortunately I’m not well versed in motorcycles and I am no mechanic. Second, it has some type of high pitched “twitter” or “squeak” coming from the engine when running. The previous owner told me it might be the water pump. It doesn’t effect the bike and I have ridden it for the last two years like that, its just a little annoying. The bike may need other things, I have changed the oil, lubed the chain and did regular maintenance on it but I don’t know much about motorcycles.

Even with these issues the motorcycle runs great and is rideable the way it is, or if someone’s wants to put some work into it they would have a really cool rare motorcycle.

The bike is fast for a 600cc and is a super fun bike. I’m just not a motorcycle person and have too many other toys.


Price: Auction <- click to see if it is still available

More info: Click here for more information
Originally listed on December 1, 2021. Older listings are displayed for reference and probably will not be available.

Seller's other items: crockett0_7

Location: Torrington, Connecticut, United States

Tip: We recommend checking the car via service like CarVertical to get its full history before placing a bid or buying. Check current promotions here.